This topic contains 10 replies, has 2 voices, and was last updated by  Kharis Sulistiyono 3 years ago.

Permalinks Problem

  • I found my publications page url previously was http://www.mywebsite.com/index.php/publications.

    But after I set the permalinks to http://mywebsite.com/sample-post/, it comes with error

    “Not Found

    The requested URL /publications/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

    Can you help me?

    Hello there,

    Thank you for asking.

    I was thinking that there is folder permission issue in your host. The folder which WordPress files are installed in should be 644 in order to make it writable and allow .htaccess file automatic creation. Once you have changed it into 644, then you should need to setup your permalink (Settings > Permalinks) again.

    If it didn’t work, you should need to create and upload .htaccess file manually through FTP or cPanel. The .htaccess file should contain the following.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    

    Please refer here for more info.

    I hope this reply helps.

    I’ll wait to hear back from you regarding your stats.

    Regards,
    Kharis

    Hi,

    I found that no .htaccess file on my public_html folder so I created the new one and upload it according to your advise.

    However it come out with new error…

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at [email protected] to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Please help me. Thank you.

    Hello there,

    Thank you for reporting.

    Could you please give me access to your FTP account and WordPress admin dashboard so I can have a look?

    Don’t forget to set your reply as private.

    Regards,
    Kharis

    This reply has been marked as private.

    Hello there,

    Thank you for the login credentials. It seems .htaccess file doesn’t exist in public_html.

    I’m afraid your server seems getting down. Could you please check it here?

    I was thinking that you should need to contact your hosting support to resolve server down issue.

    Regards,
    Kharis

    yes it has before. but i just removed it. now the site is OK after i removed it.
    but the issue still there. error page on publications page.

    Attachments:
    You must be logged in to view attached files.

    Hello there,

    Thank you for reporting.

    It seems the login credentials for WordPress dashboard access don’t work for me. Could you please do re-visit permalink setting then enable pretty permalink?

    Let me know how it goes.

    Regards,
    Kharis

    Sorry. I don’t understand. What is pretty permalinks?

    I have set the permalinks setting to post name again.

    I still have the error on publications page. and i cannot open other ages also.

    “Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at [email protected] to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.”

The topic ‘Permalinks Problem’ is closed to new replies.